Elevated Crash Rate for Peloton WearOS Watch App
Incident Report for Peloton
Identified
Team is still seeing elevated crash rates with latest release and working on an additional fix to release.
Posted Sep 10, 2024 - 07:35 EDT
Monitoring
Team has released a fix for this issue in version 3.33.0. The update will be rolling out to devices over the next few days.
Posted Sep 06, 2024 - 07:45 EDT
Investigating
We have identified an issue with the Peloton Watch App for WearOS (version 3.32.0) causing the app to crash under multiple scenarios. We have identified the root cause and are actively working on a fix for the issue.
Posted Sep 04, 2024 - 18:14 EDT
This incident affects: Bike/Tread/App/Row (Peloton App).